スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

EclipseとJDKのバージョンアップ

現状は
JDK:jdk1.5.0_14
Eclipse:wtp-all-in-one(Eclipse 3.2.0ベース)

これを
JDK:jdk1.6.0_06
Eclipse:Pleiades All in One 日本語ディストリビューション(Eclipse 3.3.2 Europaベース)
にバージョンアップする。

JDKはSunから落としてきて普通にインストール。

EclipseはC:\Program Files\eclipseにインストールする。旧バージョンはeclipse_OLDとかにリネームしておく。Pleiadesのページから20080303版(pleiades-all-in-one-java-wtp_20080303.zip)をダウンロード。解凍してディレクトリ名をeclipseにしてC:\Program Files配下に置く。

Eclipse初回起動時にワークスペースディレクトリを聞かれるから今までの所を指定(my環境ではD:\user\workspace)。

D:\user\workspace\.JETEmitters\.classpath
を開いて
<classpathentry kind="lib" path="C:/Program Files/eclipse/plugins/org.eclipse.jst.j2ee.web_1.1.3.v200701242244.jar"/>
となっているところを
<classpathentry kind="lib" path="C:/Program Files/eclipse/plugins/org.eclipse.jst.j2ee.web_1.1.104.v200709122200.jar"/>
に変更。

警告として
「Listはraw型です。総称型Listへの参照は、パラメーター化する必要があります」
が出る。.JETEmitters/src/org/eclipse/jst/j2ee/webのServletTemplate.javaの77行目らしい。
ウィンドウ→設定→Java→コンパイラー→エラー/警告→総称型→raw型の使用
を「無視」に設定する。

StrutsIDEを使いたいから、これもインストール。Project Amaterasのページから
tk.eclipse.plugin.htmleditor_2.0.5.1.zip
tk.eclipse.plugin.struts_2.0.5.zip
をダウンロード。解凍してC:\Program Files\eclipse\plugins\にコピー。

この記事のトラックバックURL

http://ysmt.blog21.fc2.com/tb.php/211-f339455d

コメント

大変参考になりました。
今回、掲示板で紹介して頂いたのですが、jdkのバージョン、Eclipseの開発環境ともに自分のと同じで物凄く参考になりました。
本当の本当にありがとうございます。
後、classpathentryに関しても大変参考になりました。

コメントする

管理者にだけ表示を許可する

Template Designed by DW99

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。