スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

JREを1.5から1.6にバージョンアップしたらヒープのエラーでTomcatが起動しない

Tomcatが動いてるサーバのJREを1.5.0_15から1.6.0_11にバージョンアップしたら
↓みたいなエラーが出てTomcatが起動しなくなった。

Error occurred during initialization of VM
Could not reserve enough space for object heap

OSは64bitでJREも64bit。メモリはたっぷり。

JAVA_OPTSは↓
-Xmx1024m -Xms1024m -XX:NewSize=256m -XX:PermSize=128m -XX:NewRatio=2 -XX:SurvivorRatio=25

どうも-XX:NewSizeの記述を無くせばエラーが出ないっぽい。

こんな感じ↓
-Xmx1024m -Xms1024m -XX:PermSize=128m -XX:NewRatio=2 -XX:SurvivorRatio=25

この記事のトラックバックURL

http://ysmt.blog21.fc2.com/tb.php/240-18297591

コメント

コメントする

管理者にだけ表示を許可する

Template Designed by DW99

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。