スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

rpmdbが壊れた

RHEL ES3の話。

パッケージのアップデートがうまくいかなくて、いじっているうちにエラーが出るようになった。

# up2date -u
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
File "/usr/sbin/up2date", line 1174, in ?
sys.exit(main() or 0)
File "/usr/sbin/up2date", line 656, in main
ret = sanityChecks(fromDaemon, hasGui)
File "/usr/sbin/up2date", line 288, in sanityChecks
if cfg["useGPG"] and gpgUtils.checkGPGInstallation() == 2:
File "gpgUtils.py", line 31, in checkGPGInstallation
File "gpgUtils.py", line 75, in findKey
File "rpmUtils.py", line 102, in installedHeadersNameVersion
TypeError: rpmdb open failed

これで対処↓
# rm -f /var/lib/rpm/__db*
# rpm -vv --rebuilddb

この記事のトラックバックURL

http://ysmt.blog21.fc2.com/tb.php/241-1919fc37

コメント

コメントする

管理者にだけ表示を許可する

Template Designed by DW99

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。